How does the editor work?

Valid for Moodle 2.8.  Updated on 8/20/2015.

Starting with version 2.8 of Moodle will have two different editors available. The default editor, TinyMCE, is documented below. The other editor, known as the Atto editor, can be accessed by editing your profile. The default editor has the advantage of giving you access to the AVrecorder function. The Atto editor has some additional accessibility features and includes a robust equation editor for those working with mathematics. For more information on the Atto editor see the documentation available through moodle.org. Please note, however, that moodle.org's documentation assumes that Atto is the default editor which is not true at Amherst.

In most places where you need to add text in Moodle you will probably find 'TinyMCE' simple and adequate.  For example to enter a description to file you're uploading you'd use the following interface.

Editor interface

Please note that by default the editor comes up with most of the editing tools hidden. Click on the Show toolbars icon  icon in the upper left corner to see all the tools.

Most text is entered simply by typing into the entry box, but the editor has many tools to assist the user. Many of these icons and functions should be familiar to anyone who uses a word processor.

 Some examples of where you will see the text editor include: Editing Section headings, description of an activity, writing an answer to a quiz question or editing the content of many blocks.

List of Icons

For those who are not familiar with the tool bar, here are the functions listed by group using the above example. Remember that the site administrator can edit or provide additonal toolbars.

Row 1

  • Show toolbars icon - Show/Hide additional tools
  • Styles icon  - Styles
  • Bold and Italic icon  - Bold, Italic
  • Lists icons  - Number and bullet lists
  • Link icons  - Link group
  • Media insertion icons  - Insert image and Insert media - uses File picker
  • Embedded files icon  - Manage embedded files

Row 2

  • HTML editor group undo redo.png - Undo and Redo group
  • more text editing icons  - Underline, strikethru, subscript and superscript
  • HTML editor group line format.png - Text justification
  •   Indent and Outdent icons - indent and outdent
  • HTML editor group color.png - Text and background color
  • HTML editor group paragraph.png - Text direction

Row 3

  • Font icons Font and size
  • HTML source icon - HTM source
  • HTML editor group find replace.png- Find and replace
  • Insertion icons  - Insert non-breaking space, custom characters, tables
  • HTML editor group formatting.png - Clean up messy code, remove formating, paste plain text, paste from Word
  • HTML editor group fullscreen 1.png - Full screen mode
  • AV Recorder icon- AV recorder - not available when sending email

Notes for selected tools

Color pickers

  • HTML editor group color.png

There are 4 levels of selecting a font or background color,

  • A quick pick 5x8 matrix of colors


    This includes a "More colors" option that links to Picker, Pallet and Named tabs.

  • A rainbow color picker tab


  • A Pallet tab with a 18x12 matrix of colors.
    Color palette interface

  • A Named tab with custom pallets.

Equation editor — Not available at the moment, please use the Atto editor instead.

Custom Character

Insert table

The insert table interface has two tabs.

  1. The general tab


  2. The advanced tab.

To add borders to a table

Cell borders are crucial for helping readers to follow the rows across the screen. If they aren’t showing already you can add them as follows:

  1. In the page containing your table, click its Edit tab
  2. Carefully select all the cells of the table
  3. Then right click (Macs: Command+click or Ctrl+Click) over any part of your selection to get a context menu; from it select Cell > Table Cell Properties; the cell properties dialog box then loads.
  4. Click on its Advanced tab, set Border Color to black (for instance), then click Apply, and then click Update.
  5. Click Save.

Note: With the exception of the AV Recorder, this documentation is based on documentation from Moodle.org

How Does the Editor Work?

Valid for Moodle 2.8.  Updated on 8/20/2015.

Starting with version 2.8 of Moodle will have two different editors available. The default editor, TinyMCE, is documented below. The other editor, known as the Atto editor, can be accessed by editing your profile. The default editor has the advantage of giving you access to the AVrecorder function. The Atto editor has some additional accessibility features and includes a robust equation editor for those working with mathematics. For more information on the Atto editor see the documentation available through moodle.org. Please note, however, that moodle.org's documentation assumes that Atto is the default editor which is not true at Amherst.

In most places where you need to add text in Moodle you will probably find 'TinyMCE' simple and adequate.  For example to enter a description to file you're uploading you'd use the following interface.

Editor interface

Please note that by default the editor comes up with most of the editing tools hidden. Click on the Show toolbars icon  icon in the upper left corner to see all the tools.

Most text is entered simply by typing into the entry box, but the editor has many tools to assist the user. Many of these icons and functions should be familiar to anyone who uses a word processor.

 Some examples of where you will see the text editor include: Editing Section headings, description of an activity, writing an answer to a quiz question or editing the content of many blocks.

List of Icons

For those who are not familiar with the tool bar, here are the functions listed by group using the above example. Remember that the site administrator can edit or provide additonal toolbars.

Row 1

  • Show toolbars icon - Show/Hide additional tools
  • Styles icon  - Styles
  • Bold and Italic icon  - Bold, Italic
  • Lists icons  - Number and bullet lists
  • Link icons  - Link group
  • Media insertion icons  - Insert image and Insert media - uses File picker
  • Embedded files icon  - Manage embedded files

Row 2

  • HTML editor group undo redo.png - Undo and Redo group
  • more text editing icons  - Underline, strikethru, subscript and superscript
  • HTML editor group line format.png - Text justification
  •   Indent and Outdent icons - indent and outdent
  • HTML editor group color.png - Text and background color
  • HTML editor group paragraph.png - Text direction

Row 3

  • Font icons Font and size
  • HTML source icon - HTM source
  • HTML editor group find replace.png- Find and replace
  • Insertion icons  - Insert non-breaking space, custom characters, tables
  • HTML editor group formatting.png - Clean up messy code, remove formating, paste plain text, paste from Word
  • HTML editor group fullscreen 1.png - Full screen mode
  • AV Recorder icon - AV recorder - not available when sending email

Notes for selected tools

Color pickers

  • HTML editor group color.png

There are 4 levels of selecting a font or background color,

  • A quick pick 5x8 matrix of colors


    This includes a "More colors" option that links to Picker, Pallet and Named tabs.

  • A rainbow color picker tab


  • A Pallet tab with a 18x12 matrix of colors.
    Color palette interface

  • A Named tab with custom pallets.

Equation editor — Not available at the moment, please use the Atto editor instead.

Custom Character

Insert table

The insert table interface has two tabs.

  1. The general tab


  2. The advanced tab.

To add borders to a table

Cell borders are crucial for helping readers to follow the rows across the screen. If they aren’t showing already you can add them as follows:

  1. In the page containing your table, click its Edit tab
  2. Carefully select all the cells of the table
  3. Then right click (Macs: Command+click or Ctrl+Click) over any part of your selection to get a context menu; from it select Cell > Table Cell Properties; the cell properties dialog box then loads.
  4. Click on its Advanced tab, set Border Color to black (for instance), then click Apply, and then click Update.
  5. Click Save.

Note: With the exception of the AV Recorder, this documentation is based on documentation from Moodle.org